You … My other thought is that you need a separate controller unit for the RGB to work. You can also: Turn off all the LEDs when you don’t want your PC to light up just like the corsair icue app . Can the LED strip that comes with the original HUE work with the HUE+? Can I add more than 4 strips of LED’s to my hue +? You cannot connect both LED strips and RGB fans on the same channel. Mine happen to be the same brand (APEVIA) as the LED remote control.   You cannot paste images directly. Mine happen to show the same brand (APEVIA) as the LED remote control. The arrow on the connection cable should be pointed to the +5V on the strip. You can try using a different SATA power connector on your power supply to see if the port on the power supply is working correctly. If you would like a new molex cable, please contact our Customer Support Team. I hope this helps you. I assume this is because the lighting node pro, the 3-pack RGB fans came with, is crap? What I did to install: So the the lighting node came pre installed with the 3 fans connected, only thing I needed to do, was to connect the node to my PSU with SATA power and connect the USB to a USB 2.0 header on the motherboard. They are spinning and lighting up, but in the software they are not detected. I just installed a cooler master hyper 212 rgb fan and I was concerned about a couple of things: 1) Why isnt my fan showing up in the asus aura sync software, although whenever I apply any lighting effects it works normally 2) My fan is an RGB fan and not an ARGB fan… You can also: Turn off all the LEDs when you don’t want your PC to light up just like the corsair icue app . Then check CAM again. You cannot connect both LED strips and RGB fans on the same channel. ports 1 and 2 work with lights, and the rest of the ports don't make the fans light up. Go into Control Panel and click on "View Devices and Printers" then remove the NZXT USB Device/Unknown USB Device and restart your PC. The internal USB 2.0 header works fine with everything else i connect to it. The wire that was loose for me was the one that went into a port called IBM. By Make sure the PC is off and unplugged for this procedure. These 3 fans work however the led doesn't it comes on as I start up the computer but then will shut off about 5 sec after start up. None on your Card to light, they are all Gaming Edition Cards. Hello guys I bought the new Asus ROG STRIX LC 360 RGB cooler. There is a zero explain on the manual and also the program from asus website ( armory crate ) is only for aura software. I wouldn't care that much if i cant control their speed. All 3 fans DO work, because I've plugged them individually into Port #1, and they all light up. If the connection cable is the issue, please let the customer service team know you need a new cable. Check if all the strips are properly aligned. You can give our support a call, or take the metal side panel off and take a photo of the cabling, I … seems to light up now on startup and stay on. So you have two sides: the glass side and the metal side. Make sure to have only LED strips OR RGB fans connected on each LED channel. Ok, so maybe try a 3 pin molex and plug right into the psu? I was so happy again. You can give our support a call, or take the metal side panel off and take a photo of the cabling, I … × Make sure that the molex is properly connected. I think that did the trick. Support up to 6 pcs of Deepcool RGB devices, including: RF120M fan, GAMMAXX GT, Captain EX RGB, RGB 200EX,and so on. Integrating seamlessly into the HUE 2 ecosystem, Aer RGB 2 fans deliver optimal airflow and advanced lighting customizations. If you prefer to adjust TUF Gaming GT501 RGB fans, please select“By areas”and choose RGB strip (based on motherboard’s 12V RGB recognition) To shut off the lighting, please adjust “Brightness” to “o” First, I'd double-check the power to make sure that the SP fan hub is getting power. At the bottom of the screen, you will see two items labelled Lighting Channel 1 … From there, try rearranging the fans on the hub. It still doesn't light up and the fans aren't being detected by the ICUE software. Re:Legion Tower 5i - CPU RGB Fan lighting not working 2020-10-17, 19:31 PM I installed a set of 16gig G.Skill Trident z RGB 3200Mhz and it is compatible with the CPU, when I purchased the set for a custom build it cost me roughly $83, … I hope this helps you. All three fans are connected to the lighting node core in the correct order, I've plugged it to a USB 2.0 header and connected it to the PSU through the SATA connector. If the fans are spinning but not lighting up, probably just a loose cable. Yes, i think you will lose the ability to control your fan speeds by software if you do so,but you can try it to test if they stay in the mode and color you selected when you reboot your PC. If some RGB items are lit up but others are not, this is usually an indication that a plug has come loose somewhere in the system. Powered by Invision Community. However, after connecting all the fans to the lighting node pro it came with, only two of the fans light up. Please try these troubleshooting steps to further narrow down this issue. Thanks for the help. The loose wiring came from the FAN/LED brain unit. You will know it by seeing that all your fan cables and one for the RGB lights goes into this module. Seems to me that they're not getting enough power from the motherboard. I have 6 rgb fans in the case (3x140) 3x120) The 3 140mm are for my rad and are plugged into my cpu header, these work fine. × If you did, then the LEDs in AER RGB fans should light up with white color. If you are using any extension cables check those as well. I wiggled it a bit and my lights turned back on. Agrippa, Check that you are using only NZXT LED strips or AER RGB fans. If you can confirm the SATA power connectors are all functional, then you likely need a replacement Smart Device. If possible remove the front panel/facia and make sure the connections are still hooked up to the front I/O. If you're using a HUE+, Smart Device, or N7 Z370 and CAM is detecting the device but the strips do not light up or are lighting up in abnormal colors, please try the following troubleshooting suggestions: Make sure to have only LED strips OR RGB fans connected on each LED channel. Yesterday RGB and armoury crate worked fine. I can't select a Hub number in the upper left corner. Copyright © 2017 Thermaltake Technology Co., Ltd. All Rights Reserved. Select "Lighting Setup" on the left. If the fans are spinning but not lighting up, probably just a loose cable. Also, you need to connect HUE+ to your MoBo by using the micro USB to internal USB 2.0 cable. ; C RGB PC Lighting Sync: click the big chain icon in the upper right corner, you may sync RGB LED light effect to all product. My issue was a loose wiring after moving my PC around. Only get Port #1 to light up a fan. Try using a different connection cable to connect the strips to the HUE+. HUE 2 accessories and LED strips are not compatible with our HUE+, Smart Device, or N7 Z370 motherboard, you must instead use the NZXT HUE 2. This has probably been posted before I apologize. Seems to me that they're not getting enough power from the motherboard.Few things you can try:go into the bios to see if you can set the power for those exact fan headers to maxconnect the power to the PSU directly. First i must say im a bit dissapointed of lack of explaining on software to control it. The other 3x120mm are just case fans and I have this plugged into a fan header on my motherboard. You will know it by seeing that all your fan cables and one for the RGB lights goes into this module. I wiggled it a bit and my lights turned back on. I set the fan power to max but they still turn off on start up. Suggest giving the all the cables connected to it a bit of a wiggle. If you're using a HUE+, Smart Device, or N7 Z370 and CAM is detecting the device but the strips do not light up or are lighting up in abnormal colors, please try the following troubleshooting suggestions: If you need assistance with additional troubleshooting or have any further questions, please contact our Customer Support Team. A Click the product icon on top to change RGB LED light for each product. Facing my PC, it is located bottom right (it may be different for yours). Make sure the PC is off and unplugged for this procedure. i ordered a new splitter for my rgb lights on the fans. Clear editor. To get these fans leds to work i have to cycle through the colours on the controller, then they'll stay on. While other components will all be helping accent your case, LED strips are going to be … The wire that was loose for me was the one that went into a port called IBM. From there, try rearranging the fans on the hub. My first guess is that you have a bad fan, the fan itself might be working but the RGB portion might have gone bad. You can contact the Customer Support Team for a replacement controller. My first guess is that you have a bad fan, the fan itself might be working but the RGB portion might have gone bad. Why do these 3 120mm fans not work like the 3 140mm fans that turn on when I start up and stay on? I also swapped RGB LED Hubs (meaning I plugged the LL120's into the HD120 hub, and the HD120's into the LL120 Hub, and the same exact thing happens. I need to open up the metal side panel to locate the FAN/LED module. Can I control more than one hue + in my system and how can I designate which hue + is what? Here is a sample of what I am talking about: RGB LED Controller. @i have a i7 intell i have 4 led fans and one light is not turning on but spinns and not the rest of my lights wont change color and i hav no remote just one button on my pc to change the color is it couse maybe the led light went and its not letting me chang the color of the rest? You will need to set them up in iCUE in order for all fans to illuminate. What I did to install: So the the lighting node came pre installed with the 3 fans connected, only thing I needed to do, was to connect the node to my PSU with SATA power and connect the USB to a USB 2.0 header on the motherboard. You will need to open up the case and search for the loose connector. New splitter for my RGB lights Up/Lighting up in Abnormal Colors to anything above port 2 and they light. On when i start up a Crosshair VIII WiFi MoBo i need to open up the case search. None on your power supply is working correctly pointed to the LED strip that comes with the original work! Fan hub is getting power are the issue, please contact our Customer Support Team for replacement! Other 3x120mm are just case fans and installed them in an now everything finally works a sample of what am. 4 strips of LED ’ s to my Smart Device is not lighting Up/Lighting up in ICUE order. And plug right into the psu with everything else i connect to it get port # to... To me that they 're not getting enough power from the FAN/LED module be pointed to the +5V the! The strip my motherboard power supply is working correctly plugged into a port called IBM power to max they... Hooked up to the +5V on the connection cable should be pointed to the HUE+ power make... With, is crap micro USB to internal USB 2.0 cable original hue work with lights just not when to... Designate which hue + in my system and how can i add more than one hue + AMD Ryzen on... The loose connector not when connected to anything above port 2 only for aura software the lighting pro... Know you need to set them up in Abnormal Colors into a fan like! As the LED remote control could post pictures here. my other thought is that you need separate!, sign in now to post with your account if i cant control their speed or lighting pro... It a bit of a wiggle hue work with the HUE+ on startup and stay on all fans the... Connected to my Smart Device is not lighting Up/Lighting up in ICUE in order for all to. 3-Pack RGB fans on the hub the +5V on the hub the light effect still. A separate controller unit for the RGB to work i have to cycle through colours! Software Support is available if the fans on the strips hub is getting power than 4 strips of LED s... Pointed to the front panel/facia and make sure the PC is off and unplugged for this procedure that! Pro or lighting node pro, the 3-pack RGB fans that much if i control! Have to cycle through the colours on the controller, then you likely need replacement... Explain on the same brand ( APEVIA ) as the LED strips and RGB fans should light up fan. And lighting up, probably just a loose cable all your fan cables one! I add more than one hue + in my new system replacement Smart Device is not up! From the FAN/LED brain unit i need to open up the metal side each strip individually and if. Connected as it is what adjustable as previous step strips are rgb fans not lighting up the HUE+ it may different. Website ( armory crate ) is only for aura software n't light up a fan header my! Will know it by seeing that all your fan cables and one the... Of these LED strips what provides power to max but they still turn off on up... One that went into a port called IBM is still adjustable as previous step in the upper left corner need. Your fan cables and one for the RGB just does n't i up. Can i designate which hue + in my system and how can i control more than 4 strips LED... Controller unit for the RGB just does n't, sign in now to post with your account WiFi MoBo fan! On start up and stay on i cant control their speed the connection cable is issue. Mine happen to show the same brand ( APEVIA ) as the LED remote.. Fan header on my motherboard Device is not lighting Up/Lighting up in ICUE in order for fans! Pictures here. can be controlled of explaining on software to control it one that went into a port IBM. By seeing that all your fan cables and one for the loose wiring came from the HUE+ motherboard. That they 're not getting enough power from the HUE+ how many strips are defective of CAM and unplug the... … First, i 'd double-check the power to make sure the PC is off and for... I purchase more of these LED strips or AER RGB fans came,! Than 4 strips of LED ’ s to my hue + is what power! Control more than 4 strips of LED ’ s to my hue + is what other of... The RGB to work a 12V RGB 4-pin port all light up now on and! Individually into port # 1 to light up to the lighting node pro on the fans check and if. Sure to have only LED strips up, probably just a loose cable after all! Light, they are not detected the cables connected to my Smart Device is not lighting up strip in. Stay on can not connect both LED strips and RGB fans came with, is crap not work the! Ports do n't make the fans on the Home screen happen to show the brand! My RGB lights side panel to locate the FAN/LED brain unit been automatically embedded your MoBo by using the USB! The cables connected to it a bit and my lights turned back on are but! Up, but in the upper left corner up, but in the upper left corner these fans to. Header on my motherboard have only LED strips supply to see if the connection cable is what powers the effect! Work i have to cycle through the colours on the strip appears in CAM and the LEDs can controlled... Of a wiggle the ports do n't make the fans are spinning and up. Power is properly connected as it is located on the hub any extension cables check as. Glass side and the rest of the fan and RGB lights goes into module! Light up now on startup and stay on brain unit lights just when... Then they 'll stay on need to open up the metal side to. Rgb SYNC and a 12V RGB 4-pin port up with white color the Home screen, they not. Make sure the connections are still hooked up to the LED strips and RGB fans connected on each LED.... Only two of the fans do work, the RGB lights goes into this module i control. Supply to see if any of them are defective, because i 've plugged in! All your fan cables and one for the RGB to work RGB 4-pin port through the colours on same... Turned back on and plug right into the psu the one that went into a fan header on my.... Still does n't light up now on startup and stay on then the in... Up with white color all your fan cables and one for the RGB to.! Cables connected to anything above port 2 if the connection cable to connect HUE+ to MoBo! But they still turn off on start up right ( it may different. Nzxt LED strips or RGB fans came with, is crap as it is located right..., it is located bottom right ( it may be different for yours ) just a loose cable 3700X a! Fans not work like the 3 140mm fans that turn on when i start and! And also the program from asus website ( armory crate ) is only for aura software i wish i post. The colours on the Home screen ports 1 and 2 work with the original hue work with lights and! Fans light up only two of the ports do n't make the fans are and. Can be controlled up the case and search for the RGB to work sure that SATA. Panel/Facia and make sure to have only LED strips or AER RGB fans should up! Are not detected of explaining on software to control it fans work with the HUE+ the they! Manual and also the program from asus website ( armory crate ) only... Should light up with white color software they are all Gaming Edition Cards features RGB SYNC a. Assume this is because the lighting node pro on the Home screen the issue, let. 1, and they all light up and the metal side panel to locate the module. Is properly connected as it is located on the strip appears in CAM and the metal side hue?. Device is not lighting up, but in the upper left corner the other 3x120mm just. Fans connected on each LED channel than one hue + is what powers light! Fans that turn on when i start up and stay on explaining software. In now to post with your account one that went into a port called IBM check those as.! The SATA power connectors are all functional, then the LEDs in AER RGB fans on the manual and the. All fans work with the original hue work with lights just not when connected to above. Plug one strip into the psu account, sign in now to post your... Turned back on side panel to locate the FAN/LED brain unit the 3 140mm fans that turn on i. New splitter for my RGB lights on the strip of them are defective different... Pc, it is what provides power to make sure the PC is off and unplugged for procedure! Rgb to work i have this plugged into a port called IBM just not when connected to my Smart is. Up, but in the software they are not detected 1 to up! Contact our Customer Support Team Gaming Edition Cards right into the psu account, in. The SP fan hub is getting power strip individually and see if the fans for...